Everyone want their code to be well structured but sometime due to few things we focus on functionality but forget to maintain format. A well formatted code increases readability, understanding and ultimately maintainability of the code base.
Post Fix / Suffix:
Here is some example of Postfix and Suffix we are using in our project.
Functional Type |
Name Suffix |
Examples |
Trigger |
Trigger |
AccountTrigger |
Trigger Handler |
TriggerHandler |
AccountTriggerHandler |
Trigge Action |
TriggerAction |
AccountTriggerAction |
VF Controller |
Controller |
AccountController |
VF Controller Extension |
Ext |
AccountExt |
Service Class |
Service |
AccountService |
Model / Wrapper Class |
Wrapper |
AccountWrapper |
Web Service (SOAP) |
Ws |
AccountToolsWs |
Web Service (REST) |
Rest |
AccountCreateRest |
Email Service |
EmlSvc |
AccountCreateEmlSvc |
Asynchronous (Future) |
Async |
AccountCreateAsync |
Asynchronous (Batch) |
Batch |
AccountBatchUpdate |
Scheduled Apex |
Job |
AccountCleanupJob |
Test Class |
Test |
AccountCreateTest |
Queueable Apex |
Que |
UserSyncingQue |
Visualforce Page |
-none- |
UserClone |
Visualforce Component |
Cmp |
AccountCloneCmp |
Lightning Components |
APEX NAMING CONVENTION :
Class Name : ClassNamePostFix
Class names should be unique, with first letter of each interval word capitalized.
Variable Name : List<Account> accountList;
Variables should be in mixed case with a lowercase first letter. Internal words start with capital letters. Variable names should be short and meaningful. Its should be camelCase.
Method Name : showAccountDetail();
Methods should be verbs, in mixed case with the first letter lowercase, with the first letter of each internal word capitalized. Whole words should be used and use of acronyms and abbreviations should be limited. Name should be camelCase
Constants : private static final String ACCOUNT_LIMIT ='10';
The names of variables declared class constants should be all uppercase with words separated by underscores (“_”). All uppercase letters in given format : CONSTANT_NAME.
Trigger : AccountTrigger
<ObjectName>Trigger. This should follow Salesforce Trigger Patterns - One trigger per object
Lightning Web Components Naming Convention
Html File : helloWorld.html
Use camel case to name your component and use kebab-case to reference a component in the markup.
JavaScript File : export default class HelloWorld extends LightningElement{}
Java Script Class name should be in PascalCase.
CSS File : showAccountDetail();
Methods should be verbs, in mixed case with the first letter lowercase, with the first letter of each internal word capitalized. Whole words should be used and use of acronyms and abbreviations should be limited. Name should be camelCase like
CSS Class Naming Standards
- CSS classes should be named based on the component that is being addressed
- Any name that is longer than one word, needs to be in this format : class-name
- Multi word name should be separated by a " - "
Comments
Post a Comment